Close

Bugs

Sign in to participate in this discussion.

Pictures not showing up--text instead

Many of the photos on Etsy don't show up, and instead there is just text. When I right click and choose "view image," the notice below pops up, but I don't know what to do. I don't know if it's a problem with Etsy, or with my computer. If it's with my computer, does anyone know what I can do to fix it? Thanks!

This Connection is Untrusted

You have asked Firefox to connect
securely to img1-ll.etsystatic.com, but we can't confirm that your connection is secure.
Normally, when you try to connect securely,
sites will present trusted identification to prove that you are
going to the right place. However, this site's identity can't be verified.

What Should I Do?

If you usually connect to
this site without problems, this error could mean that someone is
trying to impersonate the site, and you shouldn't continue.

18 Responses

i am having problems also with my internet explorer saying something about the security certiciate error, it's only related to etsy, not getting it anywhere else. i think there are some settings they need to update. i have sent an email to the security dept as well as posting here!

hopefully we can get this fixed
Me, too! It makes it hard to list things, because I have no way to double-check that I've uploaded the correct photos in the correct order.
I can't add images, just a blank box appears.
Same here :(
Laura, Jennifer, and Pocket Carnival, I can see all of your listing pictures when I click on any item pictures. But I can't see any of my pictures when I click on item pictures and go to each listing page. Is that only me??? Can anyone go to my shop and click on any picture? Can you see my listing pictures? I am in a panic!!!
Laura I got exactly what you got - that weird message from Firefox - yesterday. and when I finally did get in the only place pics were showing up for me was in my own shop. But in threads & my feed - just empty boxes with a lot of text. I thought it was me, so I ran a full scan with my Norton, and that seemed to fix it.

But it's happening again now - I got in ok, but pics won't load or are slow to load. The only way I can see pics in my activity feed is if I click on my shop homepage first, and then click on my AF. I KNOW it isn't my computer (and in addition to scans, I have cleared everything ion my browser numerous times).

Admin? Help!
Hi folks,

I'm detecting a variety of issues in this thread, so let me try a catch all solution. First, I'd like you to delete your browser cache and Etsy cookies. Then restart your browser. Here are a few links to help with that:

www.wikihow.com/Clear-Your-Browser%27s-Cache
www.wikihow.com/Clear-Your-Browser%27s-Cookies

Then I'd like you to check the day and time on your computers to be sure they are correct. Reset if necessary.

Let me know if any of that helps. Thanks!
In fact, just reset the time even if it looks right. Thanks!
Yes! It worked! Thank you so much, Matt! :)

Unfollow username?

Are you sure you want to stop following this person?

Report a post

Thank you for taking time to help Etsy! Please note that you will not receive a personal response about this report. We will review this post privately.

Why are you reporting this post?

Any additional comments?

Edit Post

Edit your post below. After editing, the post will be marked as edited and the date & time of the last edit displayed.

Edit Reply

Edit your post below. After editing, the post will be marked as edited and the date & time of the last edit displayed.

Enter at least 15 characters. 400 remaining.

Close

What is this?

Admin may choose to highlight awesome community posts that are friendly, answer questions, and offer informative links.

What does it do?

Highlighted posts are placed at the top of each page in a thread for greater visibility.